分享

Cloudera Manager5及CDH5在线(cloudera-manager-installer.bin)安装详细文档

本帖最后由 pig2 于 2014-10-21 19:58 编辑
问题导读:
1.Cloudera Manager5如何使用cloudera-manager-installer.bin安装?
2.Cloudera Manager5安装被中断该如何继续安装?还是重新安装?
3.安装过程cloudera server与agent不能通信该如何解决?
4.Cloudera Manager5安装是否有要求?
5.安装服务的过程中,遇到错误,该如何解决?







Cloudera Manager5安装遇到很多的问题,本来Cloudera Manager是为了简化部署,但是由于条件有限,安装Cloudera Manager如果不注意,会成为一部血泪史。为了避免、多次、重复安装不成功,所以你需要具备以下条件。



1.较好的网速
至少2m,否则现在慢的要死

2.网络要稳定
一旦网络中断,可能你花费了半天或则一天的时间,就有可能会浪费,然后重装。

3.内存要足够大
我的电脑是8G:
使用虚拟机安装
cloudera server:4G
cloudera agent:分别为2G
电脑最后很卡,而且内存爆满。
所以官网给出的10G不是没有道理的。



安装系统为ubuntu12.04




准备工作

规划三台:
cloudera scm server  内存分配4G
cloudera scm agent   内存分配2G
cloudera scm agent  内存分配2G
同时三台都需要配置hostname及hosts如下
(这里一定要配置正确否则,会面会出通信问题)
hosts配置.png
  1. #127.0.1.1      ubuntu
  2. 172.16.77.60 CDH.aboutyun.com  CDH
  3. 172.16.77.61 CDH1.aboutyun.com CDH1
  4. 172.16.77.62 CDG2.aboutyun.com CDH2
复制代码

不知道如何配置,参考ubuntu修改hostname

注意:本来想写一个完美的文档,上面有一个小失误,CDH2可以写成CDG2,这里不要照抄,而是失误,不过这个不影响,只要所有的hosts,都配置成这样,通信是没有问题的。


同时三台都安装ssh
  1. sudo apt-get install ssh
复制代码
安装ssh.png


在每台机器上执行下面操作:
  1. sudo mv /usr/bin/host /usr/bin/host.bak
复制代码
  1. echo 0 > /proc/sys/vm/swappiness
复制代码


官网介绍及cloudera-manager-installer.bin下载及安装视频





下载和运行cloudera-manager-installer.bin

1.下载cloudera-manager-installer.bin
附件下载:
cloudera-manager-installer.rar (253.69 KB, 下载次数: 678)

已有(46)人评论

跳转到指定楼层
Victor-Shy 发表于 2014-9-28 11:16:37
谢谢楼主了真是费心了还专门@了我而且对于问题更新速度真的好快
回复

使用道具 举报

Victor-Shy 发表于 2014-9-28 17:01:41
弱弱的问下楼主server和agent分别对应的是hadoop的主节点和从节点么?
回复

使用道具 举报

pig2 发表于 2014-9-28 20:02:51
Victor-Shy 发表于 2014-9-28 17:01
弱弱的问下楼主server和agent分别对应的是hadoop的主节点和从节点么?
可以这么分配。这个是自己选择的,分配的原则是内存够不够。内存够的话,可以都放在server上或则agent上。一般情况是server放master,agent放slave
回复

使用道具 举报

landylee 发表于 2014-9-29 16:11:23
回复

使用道具 举报

云一 发表于 2014-10-3 22:23:52
感谢楼主分享。学习了。
回复

使用道具 举报

bwboy 发表于 2014-10-3 22:38:03
正在试装。20M光纤网络,已经等了2小时了。。
回复

使用道具 举报

Weidongfang 发表于 2014-10-10 18:01:39
楼主,我用CentOS6.5安装发布版本时出现不适用,是什么原因呀
cdh.jpg

点评

jdk安装问题,先清理以前jdk  发表于 2015-3-15 12:21
回复

使用道具 举报

muyannian 发表于 2014-10-10 18:30:36
Weidongfang 发表于 2014-10-10 18:01
楼主,我用CentOS6.5安装发布版本时出现不适用,是什么原因呀
应该没有问题,继续往下走就可以了
回复

使用道具 举报

Weidongfang 发表于 2014-10-11 09:05:15
muyannian 发表于 2014-10-10 18:30
应该没有问题,继续往下走就可以了

感谢回答。另外感谢@pig2大神,我遇到的所有问题都能再文章中找到答案
回复

使用道具 举报

1234下一页
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

关闭

推荐上一条 /5 下一条